FeedWordPress 0.981: 1970 date bug re-fixed

Update 2007-11-21: FeedWordPress 0.981 is now out of date. You can download the latest release — 0.991 at the time of this writing — from the project homepage.

If you have been experiencing a bug with FeedWordPress 0.981, which leads to new posts from Atom feeds being dated back to 1970, then you should download a fresh copy of FWP 0.981. Some user bug reports (thanks!) alerted me to the fact that I’d accidentally packaged an older version of the MagpieRSS upgrade in the 0.981 release, which did not fix this bug. The correct version of rss.php is now included, and will solve the problem.

You can get the fix by grabbing FeedWordPress 0.981 in a gzipped tar or FeedWordPress 0.981 in a zip archive.

24 thoughts on “FeedWordPress 0.981: 1970 date bug re-fixed

  1. Greetings! I am really keen on getting my tags in delicious to show up as categories in wordpress. So far with your default installation – its not working (everything is showing up as uncategorized).

    What do I need to do for this to happen? You can see the delicious tags are being chopped here:

    http://media.bccampus.ca/davipd

    Thanks

  2. I’m finding the rss update feature to be very slow. It uses enormous amts. of cpu on my server. And if a it’s updating a site that has a new post it hangs forever.

    This may be a function of having so many site feeds on my aggregator (over 40). Can you give me any hints as to how I might fix or else diminish this problem?

  3. Since upgrading to WP2.2, I’m noticing that some of my feeds aren’t updating. When I go into update-feeds.php in my browser and try to update a single feed manually it will say “Error: I don’t syndicate ….”

    What does this mean? It says this both with and without the new magpie rss files.

    Thanks

  4. Great plugin. One question, some of the fees I have include href and img tags which i don’t want in my description field. Is there a way to get the importer to block that stuff out? Thanks

  5. Hi Rad Geek,

    First of all, great plugin! Ive been testing 0.981 on WP 2.1 (with 900 feeds) and it runs like an angle!

    Im pretty new to plugins, but not to PHP, and im gonna try to use your plugin for my new site. Now since WP 2.2 is out I was wondering if FWP 0.981 will run on WP 2.2. Have you or anyone else tried this?

    Think Im gonna give it a shot anyways and will let you know of the outcommes.

    One other question. Are you still working on this plugin? Maybe if I’m more familiar with WP plugins I can give you a hand?!

    Thx again for the great work.

    Greetings, Dennis

  6. I am working with FWP 0.981 and Atom 1.0 feeds from Google. I am getting an error message when I try to add the feed: “There was a problem adding the newsfeed. [SQL: ]”

    The sample feed displays fine and then when I press Use This Feed button I get the error message.

    Have you seen this before?

    I have used FWP 0.98 in the past for Google Video sites and it works great. But I noticed my video feeds didn’t work with 0.981 either.

    I am writing a book call WordPress on Autopilot and have include the plug-in.

    http://www.chimp-simple.com/products/wordpress-on-autopilot/

    It is working fine for non-Atom feeds.

    Thanks, S

  7. Hi, Is there any special way to apply filters to syndicated posts? I posted on WP support about this. Basically I want to apply a simple filter like the following, but though it works for regular posts, for some reason it doesn’t seem to affect syndicated posts:

    Thank you.

  8. Looks like the sample code got filtered, let me try again:

    function testfunction($content=”) { return “TESTING”.$content; } addfilter(‘thecontent’, testfunction’);

  9. I have uploaded this bugfix but it give the same error to me. Can you help me? I’ve sent you an e-mail but I didn’t get any answer…

  10. Great job… Can you tell me, please if it possible when “Permalinks point to: this website” add also link to original website (es.near post by) Many thanks

  11. I’m trying to install your interesting pluggin FeedWordPress 0.981 in my wordpress 2.2 Does it work? it doesn’t work in my blog.. I cannot display posts from my contacts in this blog. Thank you

Comments are closed.